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1 Preface

A Geographic Information System (GIS) can be a useful tool for preparing the input of models and
tools. Furthermore, in this era of Open Data ample open access data is available that can easily be
retrieved from the internet and integrated in open source desktop GIS software, such as QGIS.

These exercises will guide you through different steps that are needed to preprocess data to be used
in models and tools. In the first exercise you will learn how to register a scanned topographic map
and use it as a backdrop for digitizing vector data. In the second exercise you will learn how to import
data from spreadsheets into a GIS and to use it to join tables, manipulate the attribute table and
interpolating the data to a continuous raster layer. In the third exercise you will download open
access data from OpenStreetMap and use it for further analysis and conversion. The geodatabase will
also be introduced in this exercise. In the fourth exercise you will use map algebra for spatial
planning. Finally, you will learn how to delineate catchments and streams form digital elevation
models and to present them in maps or in an interactive webpage.

The exercises have been developed for different MSc programmes at UNESCO-IHE and tailor made
trainings in Uganda, financed by the Vitens Evides International (VEI) fund. | would like to thank Jan
Hoogendoorn and Jonne Kleijer, GIS experts from VEI, for their contribution to these exercises. In the
near future we will further update the exercises and distribute it as OpenCourseWare so the whole
community can use the course materials.

2 Learning Objectives
After following this step-by-step tutorial you will be able to:

e Use QGIS in its main functionalities, also in conjunction with plugins
e Digitize features from a scanned map or satellite image

e Import tabular data in a GIS

e Do simple vector analysis

e Interpolate point data

e Convert vector and raster data

e Reproject vector and raster data

e Use map algebra

e Use online data

e Perform catchment and stream delineation

2.1

During the next exercises we will make use of the following software:

e QGIS ver 2.14 (Essen) or higher,
e Google Earth,

e Firefox Mozilla

e MS Excel or OpenOffice Calc

You need an internet connection to download plugins or to use the open access data.



2.2 Preparation
Please note that QGIS is already installed on the laptops of UNESCO-IHE participants. Please do not
change the version and skip this section. The exercises have been tested for QGIS 2.14.x.

1) Download QGIS from http://www.qgis.org/en/site/forusers/download.html
2) Install QGIS
3) Install the exercise data from http://ocw.unesco-ihe.org

2.3 Convention
Throughout this guide we have used three different fonts according to what kind of operation we
wanted to point at:

— Calibri, is used for the main text
— Times New Roman, Italic, is used to identify software commands

— Courier New is used for text input, that is text that you have
to write in the software, or for file names


http://www.qgis.org/en/site/forusers/download.html

3 Getting familiar with QGIS

3.1 StartQGIS 2.14
You can start QGIS 2.14 Desktop by looking for it in the Start menu or using the search function.
Make sure you open the QGIS Desktop with Grass in order to have all functionality we need.

| Merkaartor -

| Microseft Office

| Microsoft Office 2013

J Microsoft Silverlight

J, Microsoft Visual C++ Compiler Package

; MSXML A0

; Music, Photos and Videos

; 05GecdW
& GRASSGIST7.04
M wmsys
= 05GeodW Shell
ﬂ; QGIS Browser 2.14.3 with GRAS56.4..
ﬂ; QGIS Browser 2.14.3 with GRASS 7.0.
@ QGIS Browser 2.14.3
4 QGIs Desktop 2.14.3 with GRASS56.4. =
fi QGIS Desktop 2.14 3 with GRASS 7.0,
# QOIS Desktop 2.14.3

4 Ot Designer with QGIS 2.1:1 ggg SEEEC
[ SAGA GIS (21.2) =t

i Setup
% uDig

. GRASSGI56.4.3 -

1 Back

Search programs and files o

3.2 The screen
Like many commercial GIS also QGIS has a "traditional" GIS layout.

It is made of the Standard System Menu or Main Menu (we will refer to Main Menu in the following
pages) which is always on the top of the software's window, of standard toolbars like the Zoom
Tools, or others that can be activated clicking in the Main Menu View and then Toolbars.

On the left hand side there is the Table of Content (Layers list) area, where all the layers displayed
are shown. To the left of this space there is a vertical toolbar, the Manage Layers toolbar.

In the centre of the window stay the Map Area, where all maps will be displayed.

More information about the QGIS Graphical User Interface can be found here:
http://docs.qgis.org/2.14/en/docs/user manual/introduction/ggis gui.html



http://docs.qgis.org/2.14/en/docs/user_manual/introduction/qgis_gui.html
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Exercise 1: Digitizing from a scanned map




4 Digitizing from a scanned map

4.1 Introduction

In order to use hardcopy maps in a GIS, they need to be scanned and georeferenced. Georeferencing
is also needed for raw remote sensing images, such as aerial photographs and satellite images.

For the best result, choose a map sheet that is clean and does not have too many folds. Use a
scanner that is large enough to scan the whole map. The resolution of the scanner should be large
enough (e.g. 1200 dpi) to have enough detail in the resulting raster maps.

For georeferencing we need to link locations on the scanned image to coordinates. There are two
ways:

1. Collect ground control points (GCPs) at locations that are clearly visible in the image, such as
bridges and junctions.

2. If the hardcopy map contains a coordinate grid, you can use the printed grid as a reference.
Make sure that you know the projection of this grid, which usually is stated on the map.

In this exercise we will use a scanned map of Mount Marcy (USGS, 1979)

(Mount Marcy New York USGS topo map 1979.JPG), which we will georeference with
the coordinate grid printed on the map. You can find the data (Data Exercise 1) on the
OpenCourseWare website (http://ocw.unesco-ihe.org/course/view.php?id=11).

4.2 Choosing the projection

Have a look at the scanned map and try to find the projection that has been used. You can use any
image viewing software for this. Which projection was used? Look for the EPSG code in
http://www.spatialreference.org and write it down.

4.3 Enable the Georeferencer GDAL plugin
The Georeferencer GDAL plugin is a core plugin, which means that it is already installed. In order to
use it, you need to activate it. This works as follows:

1. Inthe main menu go to Plugins = Manage and install plugins...
2. Search for Georeferencer GDAL and check the box
3. Click Close to close the dialogue

- — — — — N
£ Plugins | All (26) [
Search | georef ]

[ Georeferencer GDAL

Georeferencer GDAL

Georeferencing rasters using GDAL

Category: Raster

Installed version: Version 3.1.9 (in
C:/0SGEO4~1/apps/qgis/plugins/georefplugin.dil)

Kl | G

[ Upgrade al ] [lenstal\ p\ug\nl [ Reinstall plugin ]

Close Help



http://www.spatialreference.org/

4.4 Importing the scanned map into the Georeference GDAL plugin
1. From the main menu choose Raster > Georeferencer - Georeferencer...

Raster | Database ‘Web Processing Help

:E_; Raster Calculatar. ..

Projections & mi ab abc abg
Conversion L | — - e
Extraction &
Analysis 4
Mizcellaneous 4
GdalTools Settings. ..

2. Click the Open Raster button
Browse to the Mount Marcy New York USGS topo map 1979.JPG file

w

¥

4. A window will open where you have to specify the Coordinate Reference System (CRS) of this
input map. It does not yet have a CRS, so you can click Cancel.

4.5 Setting the transformation parameters
First we have to set the transformation settings (see also screenshot on next page).

1. Inthe menu choose Settings > Transformation Settings...
2. Here you can choose:

a.

C.

Different transformation types. A simple linear transformation can be used if the
map is not much deformed. The other ones can be tried when more deformation
exists. We will start with a linear transformation.

Resampling method: if you need the pixel values in further calculations, it is best to
choose the nearest neighbor option. This resampling method will preserve as much
as possible the original pixel values by choosing the nearest one. Visually, however,
this method results in a “blocky” map. If the purpose is only for visual use, for
example as a backdrop for digitization of vector layers, then it is better to choose
another resampling method. Here we will use the cubic method, which uses the
average of the 4 nearest pixels.

Target CRS: here choose the code that you have noted before; EPSG: 26718

Browse to the folder where you want to safe the georeferenced map. The tool automatically

adds modified to the file name. So in our case the georeferenced file will be named
Mount Marcy New York USGS topo map 1979 modified.tif

Keep the other settings on default and check the box Load in QGIS when done. The dialogue
should look like the one below.



-
,q’: Transformation settings J. ‘ - ‘ g gl
r

Transformation parameters

Transformation type Linear -
Resampling method Cubic -
Target SRS Selected CRS (EPSG: 26718, NAD27 / UTH |+
Output settings

Output raster | D:ftemp/Mount_Marcy_New_York_USGS_topo_map_1972_modified. tif [I]
Compression | Mone -

Create world file only {linear transforms)

IUse 0 for transparency when needed

Set target resolution
Horizontal [ 1.00000 =
Vertical [-1.00000 =
Reports

Generate PDF map

Generate PDF report

ais

® Load in QGIS when done

4.6 Adding Ground Control Points (GCPs)
In order to link the file coordinates to real world coordinates, we need to indicate Ground Control
Points (GCPs) with known coordinates. We can derive these coordinates in different ways:

The easiest way is to use the coordinate grid on the scanned map if this is available and if it is
in a known projection. We click on a node in the grid and type the corresponding X and Y
coordinates in the dialogue.

Using a reference map in the QGIS map canvas that has already been georeferenced. In this
way we can obtain the right coordinates by clicking on the reference map.

Using GCPs that were measured in the field using a GPS.

Here we will use the coordinate grid that is printed on the map.

1. Zoom in on the coordinate 581000 East and 4885000 North.

2. Click the Add Point button *% to add a GCP.



3.

4.

Enter the map coordinates in the pop-up window:

Enter X and Y coordinates (DMS (dd mmr s5.55), DD (ol o) or projected coordinates (mmmr. )
which correspond with the selected point on the image. Alternatively, dick the button with icon of a
pendl and then dick a corresponding point on map canvas of QGIS to fill in coordinates of that
point.

| X /East | 531000 ¥ [North | 4335000 |

Snap to background layers

- f From map canvas Cancel

s . N S

If you have a reference map in the QGIS map canvas, you can use the From map canvas
button to capture the coordinate. Here we will only type the coordinates form the map grid.
Press OK. Now your screen should look like this:

r =
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GCP table

Visible D Source X Source Y Dest. X Dest. Y dX (pixels) dY (pixels) Residual (pixels) |

x 0 338.65 -365.047 581000 4.885e+06 0 0 0|
| Transform: Not set || 696,-392 || None | 4

The red dot is the location that you have referenced. In the table below the map, you can see
the Source X and Source Y coordinates. These are the unreferenced file coordinates. Their
values depend on which pixel you clicked for placing the GCP, so it can differ from the
screenshot above. Dest. X and Dest. Y show the real world coordinates that you have linked
to this location. The other fields of the table have to do with estimated accuracy and will be
filled in after adding more points.




5. Let’s choose a second GCP in the upper right corner of the map and proceed in a similar way
as with the first GCP. Your screen should look like this:

r - Al
(i Georeferencer - Mount Marcy_New_York USGS_topo_map_1979.JPG ‘ - & @Eﬂ

File Edit View Settings
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You can see that some error statistics have been calculated. With only two points this does
not make much sense. The minimum amount of GCPs for a linear transformation should be
4,

6. Addin asimilar way a GCP in the lower left and the lower right corner of the map. If you

C
made a mistake you can remove the GCP by using the Delete point button “*Your screen
should look like this:

/ Georeferencer - Mount, Marcy_New York_USGS topo_map 1979JPG ‘ ' & ! E@u
File Edit View Settings
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At the bottom of the screen you can see the estimated mean error in the map units (40.4217
meters in our case). The error is also indicated at the GCPs using a red line. The large error
suggests that the deformation is too large to use a linear transformation. If we change to
another transformation type in the transformation settings, the error values will be
recalculated.

7. Inthe menu go again to Settings = Transformation Settings... and now let’s select a 1** order
polynomial (Polyniomial 1) instead of the linear transformation. Keep the rest as it was. Click
OK to return to the GCP table. Now you can see that the mean error has been reduced to
0.505627 m, which is acceptable.

8. Now we can start georeferencing using the button. After some calculation time the
georeferenced map appears in the QGIS map canvas. You can close the Georeferencing
plugin. It will ask if you want to save your GCPs. You can click Discard if you don’t want to use
them. If you save them, you can load them again in the Georeferencing plugin.

9. In order to verify the result you can use the Coordinate Capture plugin. If it is not activated
yet you can do it by choosing from the menu: Plugins - Manage and Install Plugins... . Then
search for the Coordinate Capture plugin and check the box to activate and click Close:

7 Plugins | All (26) r . - - - ==
a al Search | coord a

2] [ : Coordinate Capture | -
B st * ’ Coordinate Capture

Settings i in di
# B Capture mouse coordinates in different CRS

Category: Vector I

Installed version: Version 0.1 (in
C:/0SGED4~1/apps/qgis/plugins/coordinatecaptureplugin.dll)

Gl J

[[uparade i | [uninstall piugin ] [ Reinstzll plugin |

===

Close Help

10. A panel has appeared under the layers list. Here you click on Start capture. Click on a grid
node in the map and the coordinates are displayed in the panel:

Coordinate Capture

-73.900365,44.11292

@ 587995.722,4885002.452

Copy to dipboard

—:!-— Start capture

Read the coordinates from the side of the map and verify if they are correct.

11. Another way to verify the result is to use the QuickMapServices plugin web maps as a
backdrop. If not yet installed, install the QuickMapServices plugin: in the main menu choose
Plugins > Manage and Install Plugins... and search for the QuickMapServices plugin and
install.

After installing, choose from the main menu Web > QuickMapServices plugin and try some
of the options.



4.7 Digitizing vector layers from a georeferenced backdrop
Our georeferenced scanned map can now be used as a backdrop to digitize vector layers. Vectors can
be points, (poly)lines or polygons. In this exercise we are going to digitize:

e Mountain tops as points
e Rivers as (poly)lines
e Lakes as polygons
The following steps guide you through the process.

1. First we have to create an empty shapefile. In the main menu select Layer - Create Layer
- New Shapefile Layer...

£ QGIS 2.10.0-Pisa
Project Edit  View

O

Create Layer ' o New Shapefile Layer... Crl+5hift+h

Add Layer " | £7, New SpatiaLite Layer... Ctrl+Shift+A
Embed Layers and Groups. ..

Add from Layer Definition File...

Settings  Flugins Vector Raster Database Web Progessing Help

., New Temporary Scratch Layer...
u Create new GPX layer

Copy style

Paste stvle |

2. Inthe New Vector Layer dialogue we specify that we are creating a Point layer. For the CRS
we select the one of the topographical background map (EPSG:26718). You can use the
arrow to choose the right projection from the dropdown list. Next, we have to create a new
attribute. In the attribute list you can see that by default there is an attribute called id. We
will create one with the name Elevation. For type we choose Whole number and Width 4.
This means that we can store integer values up to 9999, which is sufficient for any mountain

on Earth.
3. Click the button Add to attributes list. The attribute is now added. The dialogue should look
like this:
[ /. New Vector Layer . &I&Jw
Type
® Point Line Palygon
File encoding System -
selected CRS (EPSG: 26718, NAD27 [ UTM zone 18N)
I
i New attribute
MName
Type | Whole number -
Width [4 Predsion | ]
[ Add to attributes list l
Attributes list
Name Type | Width Predision |
id Integer 10
Elevation Integer 4
Cancel Help
4. Click OK.
5. Browse to the folder where you want to store your data and name it peaks. shp and press
OK.

6. The empty shapefile has now been added to your layers list.



10.

. QGIS 2.10.0-Pisa

Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help
BB R AME @ 30 0
R AL L SRPL

- b  ‘abe

=< o aE [y

[ 3R g - e

X © peaks
% [ Mount_Marcy_New_York_USGS_topo...

uauvgtﬁ <'

In order to start digitizing, you have to toggle to edit mode. Click on the peaks layersoitis

selected.

Click on # to toggle to editing mode. Now the other editing buttons become active and a
pencil before the layer name shows that we are editing the layer.
In the topographical map navigate to a spot height of a mountain. They are indicated with x

and an elevation value. If you have found one, zoom in and click the Add Feature button®™ .
Move the mouse to the mountain top. The cursor changes in a crosshair. Click on the

mountain top.



11. A dialogue with a form shows up. Here you can fill in the attribute values: id = 1 and
Elevation = 738
o L

J— L
'-r-__F P peaks - Feature Attributes L [ ]

id 1 o

Elevation | 738 o

* 738,
1 T

12. Repeat this step for a few other peaks. If you made a mistake, you can use ENd to select the

point feature and T to delete the selected point feature. This button Eﬂ can be used to

move a point feature. Use B to save the edits.

13. When done, click again on the ¥ button to toggle editing. If you didn’t save edits yet, it will
ask you to Save or Discard. With Discard you can always undo your edits until the last time it
was saved.

14. You can check the attribute table of your new point vector layer by right clicking on the layer
name (peaks) and selecting Open Attribute Table

Layers @x

Vo aevann
L3 g— 1
|y Zoom o Loyer :
'D Shma inouernen ; .
i, [l Remove /. Attribute table - peaks : Features total: 4, filtered: 4, selected; 0 (2= | (=) |l S
Q ] Duplicate — B
- = e i . —
a Set Layer Scale Visibility v m| & & & % D = =
% Setlayer CRS id | Elevation ‘
Set Project CRS from Layer i -
@ Styles » 0
%3 & Open Attribute Table T 2 1202
Toggle Editin -
s e 3 1327
i Save As... 2
- Save As Layer Definition File... W Yy 1338
% Eilter.. B
Y Show Feature Count I
<
o a— |
Ll 1 Show All Features = &=
LEE Rene -
——— e — J

Now you can see the attributes that you have added and their id and elevation values.

15. Our next task is to digitize line features. The procedure is similar to creating a point layer. In
the New Vector Layer dialogue now you choose Line. As a new attribute we add River
Name with the type Text. Keep the width at 80. Check if the dialogue resembles the one
below and click OK. Call the new vector layer streams. shp.

7 New Vector Layer ===
Type
Point ® Line Polygon
File encading System -
Selected CRS (EPSG: 26718, NAD27 / UTM zane 18N) -
[}
U New attribute
Name
Type |Textdata -
width [0 Precision | ]
[ Add to attributes list ]
Attributes list
Name Type |width | Precision |
id Integer 10
River_MName String 80




4.8

16.

17.
18.

19.

20.

21.

In the layers list select the streams layer and toggle editing.

Click on ' to add a new line feature. Zoom and pan on the map to find a stream to digitize.
Click on the starting point of the line (node) and click when necessary to make a vertex. You
can use the zoom and pan buttons to trace the stream. You can also change the symbology

to visualize clearer the line that you are digitizing. After you placed the end node of the line,

click right.
In the dialogue, fillin id = 1 and the name of the river.
./, streams - Feature Attributes P [
id 1 a
River Name ‘S\de Erook] ]
Cancel

Repeat these steps for a few streams and save your edits. Check the attribute table. If you
want to add tributaries that connect to streams, play around with the snapping settings (in
the main menu go to Settings = Snapping options...)

Finally we are going to create a polygon vector layer for some lakes. Try to find out yourself
how to do this. It is very similar to the procedure for lines. The only difference is that the first

node should be the same as the last node in order to close the polygon.

Image to image registration

Try to use the Georeferencer plugin to register the scanned map (JPG file) to a satellite image
from the OpenLayers Plugin. In this way you can perform an image to image registration. Please
make sure you use the right projection. Does the image to image registration give better results?

This whole exercise can be viewed in a screencast
at: https://youtu.be/4IWyVeGhzog




Exercise 2: Importing tabular data into GIS
and interpolation




5 Importing tabular data into a GIS

5.1

After this exercise you are able to import tabular data into a GIS. In this example we are going to
import a table with the daily average temperature on September 1st 2013 at several meteorological
stations in the Netherlands. The data was downloaded from the KNMI Data Centre (KNMI, the Royal
Netherlands Meteorological Institute, http://data.knmi.nl), but reformatted for the purpose of this
exercise.

In this exercise we'll use the following data:

e KNMI 20130901 tday.xls:table with average daily temperatures for different stations
e KNMI stations.xls:table with station number and coordinates of the location of the
stations

This data can be downloaded from the OpenCourseWare website (http://ocw.unesco-
ihe.org/course/view.php?id=11). You can find the data under Data Exercise 2.

This exercise will guide you through the following steps:

e Convert Excel tables to comma separated files

e Import tables into GIS

e Join table with data to vector layer with locations
e Reproject dataset to local projection

e Recalculate values in an attribute table

e Interpolate vector to raster

5.2

1. Open the files KNMI 20130901 tday.xlsand KNMI stations.xlsina
spreadsheet program (e.g. MS Excel) and check the contents. Which file contains
coordinates? Is there a way to link both files? How could we do that?

2. Start QGIS Desktop
In the menu go to Plugins - Manage and install plugins... and check if XyTools is installed. If
not, you should install the plugin. Plugins are developed by the community to add extra
functionality to QGIS. With the XyTools plugin you can import from/export to Excel files for
example. Note that XyTools can only work with . x1s files. If you have files in . x1sx format,
you need to saveitin . x1s format from Excel.

4. Now in the menu choose Vector > XyTools - Open Excel files as attribute table or Point
layer
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/. QGIS 24.0-Chugiak

Project Edit View Layer Setfings Plugins | Vector | Raster Database Web MMQGIS Processing Help
=] ™ [Eh Coordinate Capture 4 ﬂ &(\ > é(a o~ " 2 - .
0 o, R [l e 7 o A R G e T Oy
— P GPS 4
” ] °° @ o B - . e
; i 2 abg| by (abc| (absl ‘abcl ‘abd
L ‘ ¥ e o /R X} OpenStreetMap 4 L] = L oW 9 (S o
n n 3ge 8 g Photo2Shape 4
0B 0B 50K (% 6 6 | e [ o
Layes Spatial Query 4
WV Topology Checker 4
F
00! X3 Save attribute table as Point shape file
'ﬂ £ analysis Toals * |5 save attribute table as Excel file
' s Research Tooks L8 (=7 Open Excel file as atiribute table or Point layer
= £} Geoprocessing Tools * |[E8 open Libre/OpenOffice Calc file as attribute table or Point layer
ﬁ %9 Geometry Tools * | &) About
T e W
a Data ManagementTools  *

R & Help

5. Inthe dialogue browse to the file with the locations of the meteorological stations
(KNMI stations.xls)
6. Browse to the file and give the proper parameters in the dialogue and click OK.
7. Next you're asked to give the Coordinate Reference System (CRS). Here choose WGS 84
(EPSG:4326), which is lat/lon with datum WGS 84. Click OK to proceed.
N

/1 Coordinate Reference System Selector | ? &
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8. Next, a dialogue pops up where you have to choose the columns with the x and y
coordinates. Which columns are those? Select those and click OK.

/% X¥Tools - Coordinate fields @

Current layer: Temporary Layer {volatile)
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layer.
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columns.
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9. Now a map with the meteorological stations is displayed. If you don't see the map, you
probably need to zoom to the extent of the map: click right on the layer name (Temporary
layer (volatile) and choose Zoom to layer.

10. Rename the layer to KNMI_stations_table (Click right on the layer and select Rename).

11. Now add the table with the temperature data in the same way. When the Coordinate
Reference System is asked, click Cancel. When the popup comes that asks for the columns
with x and y coordinates, also click Cancel. This is because this table doesn't contain
georeferenced data. We have to link the two tables to make it georeferenced.

12. Rename also this layer. We call it KNMI_temperatures_table.
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13. The next step is to convert KNMI_stations_table to a GIS vector format, i.e. shapefile. Click
right on KNMI_stations_table and choose Save as...

14. In the dialogue Browse to the folder to save the file as KNMI stations.shp. Inorderto
change the projection to the local Dutch projection choose for CRS "Selected CRS" and

Browse to Amersfoort / RD New by clicking on the button. Tip: use the Filter field to
lookup EPSG code 28992:
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Select the coordinate reference system for the vector file. The data points will be transformed from the layer coordinate
reference system.
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Here you see the advantage of using EPSG codes: it standardizes the projection. So it is useful
to determine the EPSG code of the projection you want to work within your project. Also note
that all maps in your project need to be in the same projection if you want to combine them
in a GIS analysis or modelling.

Click OK. Now the dialogue looks like (also check the box Add saved file to map):
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Click OK to proceed.



15. Remove the knmi_stations_table from the display by clicking right and selecting Remove. Be
sure to remove the right one. If you hover your mouse over the layer name it will show the
file name. With Remove you only remove it from the display, the file will still be on your
harddisk.

16. Although the knmi stations.shp dataset is in the EPSG 28992 projection (Amersfoort /
RD New), the QGIS display still uses the EPSG 4326 projection (lat/lon WGS 84) and has
reprojected knmi stations.shp on the fly for visualisation. In order to visualise all
layers in EPSG 28992 we have to change the QGIS Project properties. In the menu choose
Project - Project Properties...

17. Choose the Coordinate Reference System (CRS) tab

18. Check the box "Enable 'on the fly' CRS transformation" (by default it is already checked, so
keep it checked)

19. Choose from the recently used coordinate reference systems EPSG:28992 and click OK.
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Note that the projection of the project is indicated in the lower right of the screen

w| You can always check there if the EPSG code is okay. You can change the
on-the-fly projection also by clicking on that EPSG code.

5.3 Join attribute tables

20. We still have the locations of the stations and the temperature data in separate tables. We
have to combine them in one shape file. In GIS terms this is called a "join" operation. We can
only join tables if they have a column in common. Check the attribute table of
KNMI stations (right clickon KNMI stations and choose Open attribute table) and
in the same way check the KNMI temperatures table. Which column both attribute
tables have in common?
After determining which column both tables have in common we can join the data of
KNMI temperatures table to the attributes of our shapefile
KNMI stations.shp.

21. First close the attribute tables.



22. Next, click right on KNMI stations and choose Properties.

-6
23. In the dialogue choose the button Joins .
24. Click the + sign and choose check if the dialogue looks like this one:
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[ 3 Choose which fields are joined
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Cancel

Note that the common field is STN (the station number) and click OK.
25. Now the Joins dialogue looks like this:
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Click OK to perform the Join operation.
26. Now check again the attribute table of KNMI stations. What happened?
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27. First we need to remove the missing values. Click on row numbers with NULL or no values for
temperature, while keeping the Ctr1 button pressed. Now the attribute table looks like this:




28.

29.

30.

31.

32.

- - — — —
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In the attribute table click on above the table to toggle editing mode.

Click the ﬁ icon (in the toolbar above the attribute table) to remove the 2 features with
missing data.

The only problem now is that the temperatures in the table are in 0.1 °C. We need to convert
the values to °C.

Click to add a new column to the table. And fill in the dialogue according to this
screenshot:

.
L Add column L2 [

Mame |T{C} |

Comment |Temperah_|re in Celdius |

Type |Decima| number {real) Izl

double
width |3 k]
Precision |1 B
| [ ok || cancel ||
. )

Width is the amount of numbers, Precision is the amount of decimals.
Click OK to proceed.
Now the attribute table shows an extra column with NULL values. In order to calculate the

right values click above the table to open the Field Calculator dialogue.

Fill the dialogue like the screenshot below. To avoid typos the best practice is to double click
on the field name in the middle of the dialogue screen and to click the * button. Then type
0.1. Click OK to proceed.
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33. Make sure the Attribute table window looks like below (with T(C) indicated as column to
assign the calculation). Click Update All.
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34. Now check the result in the attribute table.

35. Click again on the to toggle back to non-editing mode. Click Save to save the changes
when asked and close the attribute table. If you made a mistake choose Discard to undo all
changes since last save.

36. Now remove the table KNMI temperatures table and check the attribute table of
KNMI_stations. What columns do you see now? What can you conclude about the join
function? You could have saved the entire attribute table by saving KNMI_stations to a new
shapefile using the previously used Save as... function.

Interpolate point features to raster
37. The final task is to interpolate the temperature values to a raster. In the menu choose
Raster - Analysis > Grid (Interpolation)
If you don’t see this, your GdalTools plugin is not activated. You can activate it from the
Plugins menu.
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38. In the dialogue specify the output file: tday NN.tif by using the browse window and
specifying the . tif format.

Check the Z-field checkbox and select T (C) . This is the field that we will interpolate.

Check the Algorithm checkbox and select Nearest Neighbor. This is the interpolation function
that creates Thiessen polygons.

Check the Load into canvas when finished checkbox.

For the rest of the dialogue keep the defaults. The dialogue should now look like this:
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39.

40.

41.

42.
43.

Note that the dialogue generates a GDAL command that is given in the edit field.

Click OK to proceed.

Click 2 x OK to close the popup windows and click Close to close the dialogue

The interpolated temperature map is now loaded into the display. It is visualised in greyscale,
so you have to set the visualisation options. Click right on the map and select Properties.
Under the Style tab, play around with the different options and click OK to return to the
display.

Now drag the knmi stations file to the top in order to display the stations on top of the
temperature grid.

Click right on the knmi stations layer and select Properties.

Select the Labels icon and check the Label this layer with checkbox. Choose T (C) as the Field
containing the label. Play around with the placement options (see screenshot below) to
make a nice map. Click Apply to test and OK to visualise.

44. Now repeat the interpolation using the Inverse distance to a power (IDW) algorithm (repeat

from step 37). Call the result file tday IDW.tif. Visualise the result. Which interpolation
method is better? Why? Can you explain the temperature gradient in the map?
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45.

46.

47.

You can save your QGIS project at this point by choosing from the menu Project > Save as....
Now you can close QGIS and load the project the next time you use QGIS.

We can also plot our newly created GIS data over a topographical map. For this purpose you
have to install the QuickMapServices Plugin. In the menu go to Plugins - Manage and
install plugins... and install the QuickMapServices plugin if it is not yet installed.

Choose from the menu Web - QuickMapServices > OSM - OSM Mapnik. Make sure your
point vector layer is on top.
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This whole exercise can be viewed in a screencast
at: https://youtu.be/LKNga7cedt8




