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Executive summary

This document contains instructions and tips on how to use public data for catchment
analysis. Data are obtained from various sources, including Google Earth Engine.
Spatial data is further analysed in the Quantum Geographic Information System.
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1 Introduction

This training is part of the second training course organized by INWRDAM, IHE and Acacia
Water in May 2024. The training builds upon the first training held in Amman in
September 2023 and the online Quantum GIS training offered by IHE in April - May 2024.

This guide is used for working with Google earth Engine to obtain public data and then
process the data in QGIS to do a spatial analysis of the Al-Muwaqgqar catchment. The
Jordan University has a research station in the Al Muwaqqgar catchment where research
on water harvesting, soil conservation, crop growth and other studies related to land
management are carried out. Recently, several ponds for collecting runoff have been
redeveloped and Vallerani water harvesting has been implemented in part of the area.
However, most runoff and sediment seems to be from the upstream part of the
catchment, where water harvesting and soil conservation has also been applied locally. To
minimise the filling of the reconstructed ponds with sediment a study therefore would
need to include other parts of the catchment where sediment is generated and plan 3R
rainwater harvesting interventions such to minimise further soil degradation.

This exercise has the objective to make the participant familiar with collection of public
data and processing and combining these data in a geographic information system. At
the same time, field visits will be made for the verification of the data and to establish hot
spots for implementation of soil conservation and water harvesting measures and for
monitoring. This combination will reveal the links between the atmosphere, land cover,
soil and deeper formations that influence the hydrologic behaviour of the catchment and
sediment transport. As an example an analysis based on the Curve Number method (Lee
et al,, 2023) will be done to estimate the reduction in overland flow — direct runoff because
of the construction of soil conservation and water harvesting structures.

The exercise will be carried out in groups of participants from different institutes. If you
have not followed the QGIS introductory training from IHE, please join a group where one
or more members are familiar with QGIS.




2 Al Muwaqqar project

2.1 Create project folders and extent shapefile

For this assignment we are going to create a new al_muwaqqgar project directory on your
computer to store all the project files.

1)

Create an al_muwaqqgar project folder on your computer and create “data” and
“output” directories in the al_muwaqgqgar directory.

Now we shall start creating an extent shape covering the Al Muwaqqar catchment for the
downloading of data from Google earth Engine.

1)

2)

4)

Open QGIS and create a new project using the WGS84 Lat/Lon (EPSG:4326) as
coordinate reference system. Add openstreetmap
(https://tile.openstreetmap.org/{z}/{x}/{y}.ong) and Google satellite
(http://mt0.google.com/vt/lyrs=s&hl=en&x={x}&y={y}&z={z}) maps as background
layers to your project (in XYZ Tiles). Save this project in an al_muwaqgqgar folder on
your computer;

Download the data_training_may_2024.zip file from the OCW course site and
unpack this in your data folder

Load the streams_muwaqqar_swat shape file. Located in the streams folder, in
QGIS to view the stream network;

Based on the stream network, create a larger rectangular extent shape file with a
new polygon that covers the Al-Muwaqqgar catchment (Figure 1) and save the new
shapefile as al_muwaqgqgar_extent.shp in your data directory.
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Figure 1. Creation of an al_muwaqqar extent layer in QGIS using Google Satellite as background.

2.2 Google Earth Engine data extraction

2.2.1 Topography
Now open https://code.earthengine.google.com/ and log in to your Google account. This
will open a tab showing the GEE interface (Figure 2).
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Figure 2. GEE interface window in your browser.
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1) Inthe left panel open the Assets;

2) Add the created shape file to your Assets in Google earth Engine through the
New=>table upload menu. Upload the shp, shx, dbf and prj files from the
al_muwaqqar_extent shapefile in your data directory and wait until these are
imported;

3) Use the get_topographic_maps.js script that was made available to you in the first
course. You can download the script from the course site in OCW. Extract and save
these scripts in a gee_scripts folder in your project folder. Then open the
get_topographic_maps.js in a text editor (Notepad) and create a new script and
copy the text into the new script and save the script as get_topographic_maps.
The script may already exist in GEE from the previous training.

4) Import the al_muwaqgqgar_extent asset into your script and use the shape to
download digital elevation, slope and aspects maps in Google earth Engine. NOTE:
please uncomment lines 262 and 264 (remove //) and comment lines 263 and
265 (place // before the commands) and change the description:
'ALOS_30_m_slope' to description: 'ALOS_30_m_slope_perc' to download the
slope map in percentage rather than in degrees. The conversion from degrees to
percentage is done in line 184 of the script;

5) Use Tasks to download the elevation, slope and aspect maps. The maps will be
saved in your Google Drive, which is part of your Google account services. This may
take a while and you have to wait until the fields in the Tasks window turn blue. .

6) Download the maps from your Google Drive (https://www.google.com/drive/) and
save these in a “al_muwaqagar\data” folder.

7) Import elevation, slope and aspect maps in your QGIS project.

2.2.2 Reclassification of slope map

Slope has been recognized as influencing the curve numbers and for this reason five
slope classes were introduced, as discussed in the Curve Number Method document
published on the OCW course web site. The five classes are given in Table 1. In the
previous exercise you have downloaded a slope map of the area that we can now
reclassify into five slope classes. Load slope maps in QGIS and check if the ALOS slope
map is indeed in percentage by comparing to the other slope map.

Table 1. Slope classes defined for application in the curve number method

Slope class Steepness Description

| <1% Flat

1l 1-5% Slightly sloping
1 5-10% Highly sloping
\Y 10 - 20% Steep

\Y% >20% Very steep

The slope percentage map can map can now be recoded according to Table 1, and we are
going to use a text file with the recoding rules. Create a directory “recode_rules” in your
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project directory and copy the text below into a new text file (use Notepad) named
slope_recode_rules.txt. The rules are listed in the following format:
lower_limit:upper_limit:class_value. A * denotes “anything higher than lower limit".Note
that we use numbers instead of the roman class numbers | - V. Copy the text below in the
recode rules text file.

011
152
510:3
10:20:4
20*5

QGIS also incorporates Grass and SAGA GIS routines in the processing toolbox. If these are
not visible in the Processing Toolbox, go to Plugins > Manage and Install Plugins and
activate the Grass plugin. You can now search for r.code in the search fiueld of the
Processing Toolbox.

Open the r.recode tool in the Processing > Toolbox menu and use the slope percentage
layer as Input raster layer, load the slope_recode_rules.txt file as the File containing recode
rules, leave the Recode rules text field empty and save the Recoded file as
slope_recoded.tif in the data folder. Clip the raster to the subcatchment boundary file.
Give the layer a category color legend and see how many classes there are.

Import the subc_muwaqqgar_swat.shp catchment boundary file, located in the in the
data\catchment directory. Clip the slope map to the catchment boundary (Raster >
Extraction > Clip raster by extent) and save the clipped map as 'slope_recoded_clipped.tif'
file.

2.3 Geological map

On the QGIS and Google earth Engine refresher tab in the OCW course site you will find a
geological map (geology_jordan_bender_1975.png), in png format (Figure 3). Download
this map to your data folder and import the map into your QGIS al_muwaqgqgar project.
Note that the map is not georeferenced yet. Please georeference the map using the grid
lines as coordinate reference points. Use at least six points close to the Al Muwaqgqgar
catchment on the map for georeferencing. Use the WGS84 Lat/Lon (EPSG:4326) as
coordinate reference system.

When you have georeferenced the geological map export the map as geology_georef.tif
in your data directory. Now clip the map using the al_muwaqqgar_extent shape file and
export the map as al_muwaqggar_geology.tif in the data folder.

Create a new vector shapefile layer and digitize the geological formations, use the names
and codes in the attribute table as shown in the legend of the original map. Save the
digitized vector map as al_muwaqqgar_geology.shp. Clip the vector map to the
subc_muwaqqgar_swat.shp catchment boundary file.




GEOLOGIC MAP OF JORDAN

Figure 3. Geological map of Jordan to be used for georeferencing and digitisng formation
boundaries.

2.4 Soil maps - Hydrologic soil groups

Soil maps have been obtained from the SoilGrids data platform and are available for
download on the OCW course web site. These have been placed already in the soil
directory of the your project data folder when you unzipped the file to obtain your stream
shape file.

Import the clay_0-30cm_frac.tif and the sand_0-30cm_frac.tif and look at the ranges of
the sand and clay contents in the area. The Curve Number method works with Hydrologic
Soil Groups to estimate the infiltration capacity of the soil. There are four groups as shown
in Table 2




Table 2. Hydrologic soil group classes

Soil Group texture Description
A Coarse texture, sand and gravel High infiltration, deep well drained soils, Ks > 200 mm d”
B Fine to coarse texture, sand and Moderate infiltration, well to moderately well drained soils, Ks = 100-200
silt mm d’
C Moderately fine to fine texture Low infiltration rates, downward movement of water impeded, Ks = 30-
100 mm d”
D Clay soils, shallow soil on Low infiltration rates, poor drainage, Ks < 30 mm d’

impervious material

FutureWater has developed a 250 m resolution global map of hydrological soil groups
(Simons et al., 2020), of which a clipped maps is placed on the OCW course site. Please
download the al_muwaqqgar_hsg.tif file, save it in data\soil and then import into your QGIS
project. In this map the whole area is classified as 4, i.e. soil group D with high runoff
potential.

During the excursion to the field verification of the hydrologic soil group can form an
element of your investigations.

Clip the al_muwaqgqar_hsg.tif file to the subc_muwaqgqgar_swat.shp catchment boundary
layer.

2.5 Land cover

A land use map has been provided as part of the data for Al Muwaqgqgar and is stored in
the landcover folder. The name of the file is esa_worldcover_10m_muwaqqar.tif. Land use
is a strong determinator for the curve number. The land cover map can be verified in the
field during the excursion. Note that this map does not give any information on land
management and the presence of soil conservation rainwater harvesting interventions.
For estimating the impact of such interventions, their locations in the catchment need to
be digitized and verified.

Import the ESA landcover map (van den Kerckhove et al., 2020) into you QGIS project and
clip to the catchment boundaries as you did before for the other layers. Save the layer
with the extension _clipped to the filename.

2.6 CN value mapping

We now have the information needed to assign CN values to the different map entries,
assuming that we shall work with AMC class | (<24 mm precipitation in antecedent five
days). The maps needed are:

- Hydrologic soil groups — whole area seems to be Group D

- Slope class map (classes 1-5)

- Land cover map




- Land management map, this map is missing, we'll assume poor conditions
everywhere in the catchment for now.

Table 3. CN values for different land cover classes and slope classes, assuming poor management
and Hydrological Soil Groep (HSG) D. In Jordan Antecedent Moisture Condition (AMC) class will
usually be class I.

Land use (code) Treatment / Slope class LC-Slope code CN value HSGD CN value HSG D
management AMC 11 AMC I

Tree cover (10) Poor 1 n 77 59
Tree cover (10) Poor 2 12 83 67
Tree cover (10) Poor 3 13 87 73
Tree cover (10) Poor 4 14 90 78
Tree cover (10) Poor 5 15 92 81
Pasture / range (30)  Poor 1 31 84 68
Pasture /range (30)  Poor 2 32 89 78
Pasture /range (30)  Poor 3 33 92 81
Pasture /range (30)  Poor 4 34 94 85
Pasture /range (30)  Poor 5 35 95 87
Cropland (40) Poor 41-45 91 80
Urban / roads (50) 51-55 90 90
Fallow (60) Poor 61-65 94 85
Water (80) 81-88 100 100

We are going to use the raster calculator to combine the land cover codes with the slope
codes by just summing the two layers. This means that Tree cover will get codes 11-15,
pasture / range will get 31-35, cropland 41-45, etc. The raster calculator window is shown in
Figure 4. In the top left panel space you see the raster layer names, on the left side file
saving and CRS menu items and at the bottom Operator and Raster calculator
expressions windows. If you double click on a raster layer entry it will appear in the
Expressions window. Click on the clipped land cover layer, then on the + operator and
then on the slope class layer to add the two layers. Give the output layer a name like
Ic_slope_map, leave the format geotiff and click on OK. This will produce a new map
which is the sum of the two maps. Now we can reclass this map using the CN values in
Table 3. Create a new lc_slope_reclass.txt text file with the reclass rules:

1 =59
12=67
13=73

14 =78




15 =81

31=68
32=178
33 =281
34 =85
35=87

41thru 45 =80
51thru55=90
61thru 65=85
81thru 88 =100

Reclassify the LC_slope map to get a map with CN values. Save the CN values map (Figure
5) as CN_values_basis.tif file.

The impact of Vallerani structures on direct runoff, CN and soil moisture content in Jordan
has been studied (Goos, 2019; Mirzabaev et al., 2019). You can also use the change from
poor to good management to estimate changes in CN values and runoff. Keep in mind
that you also need to take slope and hydrologic soil group into account for determining
curve number. In this sense you may need to combine several maps to get the spatial
variation of CN values in a single map. Make a second CN values map for the area with CN
values associated to soil conservation and water harvesting methods. Note that these CN
values will be lower than those given in Table 3, except for water and urban land cover
where no interventions will be done.
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Figure 4. raster calculator window of QGIS.
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Figure 5. map with CN values of the Al Muwaqgar catchment.

2.7 Precipitation

Spatial variation

We will download two types of precipitation data. The first is the annual rainfall maps
from 1990 until 2019, and the second is a time series for a single point in the area. For
downloading the annual rainfall maps from 1990-2019 use the
chirps_precip_create_annual_maps.js script in the Google earth Engine example scripts
folder in the 2023 OCW course. Adapt the script using the al_muwaqgqgar _extent asset
shapefile to download maps for the area specified by your extent.

Download all files from your Google Drive and save these in the data folder.

Import all files in QGIS to calculate the spatial mean, median and standard deviation
values for the period 1990-2020. This can be done using r.series in the Processing >
Toolbox menu in QGIS.

Temporal variation point data
For the point data extraction in Google Earth Engine use the lat/loncoordinates of the Al
Muwaqggar meteorological station (31.7795964 °N, 36.2226539 °E) in the

il



chirps_precip_create_daily_time_series.js script on the OCW course of 2023 and run the
script in the GEE code editor. Use the period from 1January 1990 until present for
downloading.

Import the meteorological data file in the OCW GIS data folder into Excel and use Insert >
Pivot Table > From table/range to get daily sums of precipitation. Also import the
corresponding time series from CHIRPS into the Excel file and make a comparison
between the values in the CHIRPS dataset and those measured at the Al Muwaqqar
station.
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Figure 6. Comparison between measured and CHIRPS precipitation at Al Muwaqqgar station.

Frequency distribution of rainfall intensities

With the daily CHIRPS dataset we can now make a frequency distribution to see how the
daily values are distributed and to determine the maximum precipitation intensity. Note
that long time series of measured data should be used rather than CHIRPS if these are
available from the meteorological service.

We shall make bins (classes) of 5 mm, from O to 100 mm d-1 and select all the CHIRPS
daily precipitation data to look at the frequency distribution of daily precipitation. Make a
column of bins in the worksheet of your CHIRPS timeseries data. Then use the
=frequency(data array, bins) function to calculate the frequency of occurrence for each
bin. The 34 year dataset (1/1/1990 - 30/4/2024) shows that maximum daily precipitation
was between 65 and 70 mm and that precipitation between 15 and 25 mm d™' occurs
about once a year. You could also calculate the return period t,= (n+1)/m where n is the
total number of values in the data series and m is the rank with the highest value having
rank 1. To compute, sort the precipitation data from highest to lowest. Calculating the
return period of 1 year shows that this is at 2.9 mm d™.
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3 Direct Runoff calculation

With the CN value input maps and precipitation information prepared, you can now
calculate the direct runoff according to Equation 1 and Equation 2 to calculate a map of
the potential maximum retentions S [mm] and then direct runoff Q [mm] from
precipitation P [mm]:

25400 :
= - Equation 1
CN 254
Q= ﬂ Equation 2
P+(1-4)S

Where precipitation P > AS in Equation 2. A common value for A is 0.2. However, if this
yields no runoff, whereas you have observed runoff for a certain precipitation intensity you
may have to lower A. Precipitation Q, P and S are all in mm.

When you have a map of the CN values for the different areas, you can calculate new
maps for S from the CN value maps using the Raster calculator. Finally using a value for P
(e.g. annual return period P) to calculate the direct runoff Q for a base scenario and one
where interventions have been applied.
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